Glavni Pc I Mac Jesu li adrese e-pošte osjetljive na velika i mala slova?

Jesu li adrese e-pošte osjetljive na velika i mala slova?



Postoji velika zabuna oko toga razlikuju li adrese e-pošte velika i mala slova. Neki kažu da jesu, dok drugi tvrde da nisu. Pa, tko je u pravu? U ovom ćemo članku ispitati jesu li adrese e-pošte osjetljive na velika i mala slova ili ne.

Jesu li adrese e-pošte osjetljive na velika i mala slova?

Što čini e-adresu?

Adresa e-pošte sastoji se od tri dijela - lokalnog dijela (poznatog i kao korisničko ime), znaka @ i dijela domene. Svaki dio ima svoju ulogu i podliježe vlastitom skupu pravila. Evo kratkog pregleda.

Prema standardu, lokalni dio adrese e-pošte može imati do 64 znaka i može se sastojati od ograničenog skupa znakova. Uključuju velika i mala slova latinične abecede, brojeve od 0 do 9, točku i posebne znakove. Posebni znakovi uključuju `[zaštićena e-poštom] # $% ^ & * () _- + = [] {} ~. S dijelom domene povezan je znakom @.

Domena može imati najviše 255 znakova. Može sadržavati slova latinične abecede (i mala i velika slova), brojeve od 0 do 9 i crticu. Crtica ne može započeti ili završiti dio domene.

Također se mogu koristiti međunarodni simboli, ali o tome više kasnije.

Je li osjetljivo na velika i mala slova?

Točan odgovor na ovo pitanje je i da i ne. Prema RFC 5321 , lokalni dio adrese e-pošte razlikuje velika i mala slova. To znači da u teoriji, [zaštićen e-poštom] nije isto što i [zaštićen e-poštom]. Međutim, davatelji usluga e-pošte imaju slobodu tretirati lokalne dijelove i s velikim i malim slovima.

Na primjer, [zaštićena e-poštom], [zaštićena e-poštom] i [zaštićena e-poštom] teoretski su različite adrese e-pošte. Lako je vidjeti kako bi to moglo stvoriti probleme i umanjiti korisničko iskustvo ako se poslužitelj pošte odluči da lokalne dijelove tretira kao velika i mala slova. Stoga se mnogi pružatelji usluga prema lokalnom dijelu adrese e-pošte ne razlikuju između velikih i malih slova.

kako zatvoriti progoniti štedni račun

Što se tiče domene, RFC 1035 propisuje da to uvijek ne razlikuje velika i mala slova. To znači da ga možete pisati malim slovima, velikim slovom ili bilo kojom kombinacijom toga, a e-pošta će završiti na istoj adresi. U praktičnoj upotrebi, [zaštićena e-poštom], [zaštićena e-poštom] i [zaštićena e-poštom] su iste adrese e-pošte.

U praksi

Iako su adrese e-pošte samo djelomično osjetljive na velika i mala slova, općenito je sigurno da se o njima ne računa velika i mala slova. Svi glavni davatelji usluga, kao što su Gmail, Yahoo Mail, Hotmail i drugi, lokalne dijelove adresa e-pošte tretiraju kao neoslušne. S tim u vezi, trebali biste provjeriti pravila davatelja usluga e-pošte s kojim želite stvoriti e-poštu.

Vezujući se za prethodnu točku, gore spomenuti RFC 5321 preporučuje stvaranje novih adresa e-pošte malim slovima samo kako bi se izbjegla potencijalna zabuna i problemi s isporukom.

S druge strane, ako vaš prijatelj ili kolega ima adresu e-pošte s kombinacijom velikih i malih slova, preporučljivo je da je napišete onakvu kakva je kad im šaljete e-poštu. Ako to ne učinite, e-pošta ne može biti isporučena. Međutim, ovo nije problem s glavnim davateljima usluga e-pošte kao što su Gmail, Yahoo Mail, Hotmail i drugi.

Osim toga, Gmail je također neosjetljiv na točke pronađene u lokalnom dijelu e-pošte kada je u pitanju identifikacija korisničkog računa. To znači da ako račun [zaštićen e-poštom] neće biti u mogućnosti registrirati se [zaštićen e-poštom] ili [zaštićen e-poštom]

Internacionalizacija

Izvorno, adrese e-pošte mogle su se registrirati samo pomoću slova latinične abecede, brojeva i ograničenog skupa posebnih ASCII znakova. Međutim IETF (Radna skupina za internetski inženjer) naknadno je razvila pravila i standarde za uključivanje međunarodnih znakova.

RFC6530 je prvi uključio i regulirao uporabu međunarodnih znakova. RFC6531 proširio na pravila i standarde. Nakon toga su pravila i standardi ažurirani kroz RFC6532 i RFC6533 .

Sada možete registrirati adresu e-pošte pomoću širokog raspona abeceda, znakova i skripti. Neki od najčešće korištenih uključuju latinične znakove s dijakritičkim znakovima, grčku abecedu, tradicionalne kineske znakove, japanske znakove (hiragana, katakana i kanji), ćirilicu, nekoliko indijskih pisama, kao i niz drugih.

Uključivanje i kompatibilnost s međunarodnim adresama e-pošte razlikuje se od davatelja do pružatelja usluga. Čak i neki od najvećih pružatelja usluga nisu u potpunosti kompatibilni s međunarodnim adresama. Na primjer, Google vam omogućuje slanje e-pošte na međunarodnu adresu, ali vam ne dopušta stvaranje. Outlook 2016 ima sličnu funkcionalnost.

Zaključak

Za razliku od dijela imena domene, lokalni dio adrese e-pošte razlikuje velika i mala slova. To je rečeno, mnogi davatelji usluga e-pošte odlučuju ignorirati osjetljivost malih i velikih slova lokalnog dijela iz praktičnih razloga i potiču ljude da stvaraju e-poštu samo s malim slovima.

Zanimljivi Članci

Izbor Urednika

Najbolja proširenja za Chrome za promjenu IP adrese
Najbolja proširenja za Chrome za promjenu IP adrese
Ako ne koristite samostalni VPN i želite promijeniti svoju IP adresu, možete koristiti proširenje preglednika. Trebat će vam proxy proširenje ili VPN proširenje, ali oba će obaviti posao. Ako želiš
Kako poslati poruku na GroupMe
Kako poslati poruku na GroupMe
GroupMe je aplikacija za razmjenu poruka koja vam omogućuje stvaranje grupa i brzu komunikaciju s puno ljudi odjednom. Iako je zasjenjen mnogim drugim aplikacijama za razmjenu poruka, GroupMe vrijedi provjeriti. to je
Kako snimiti makronaredbe u sustavu Windows 10
Kako snimiti makronaredbe u sustavu Windows 10
https://www.youtube.com/watch?v=BS0c4VUBabs Prethodno smo raspravljali o tome kako snimiti screencast u sustavu Windows 10. Makronaredba je slična screencastu koji se izvodi poput jednostavnog računalnog programa, osim što bilježi i slijed
Kako preuzeti Cinema HD na FireStick
Kako preuzeti Cinema HD na FireStick
FireStick vam omogućuje preuzimanje aplikacija trećih strana za različite opcije strujanja. Jedan primjer je Cinema HD. Pomoću ove aplikacije možete odabrati i pogledati mnoge dostupne emisije, filmove i još mnogo toga. Međutim, postupak preuzimanja i instalacije za ovu aplikaciju je
Kako povećati ograničenje istovremenog preuzimanja u programu Internet Explorer 11
Kako povećati ograničenje istovremenog preuzimanja u programu Internet Explorer 11
Upravitelj preuzimanja u Internet Exploreru ima ograničenje za količinu istodobno pokrenutih prijenosa ili preuzimanja. Na primjer, u programu Internet Explorer 9 ograničeno je samo na 6 preuzimanja. Uz IE10 i novije verzije, Microsoft je povećao ovo ograničenje na 8 preuzimanja. Ako vam je ovaj iznos nedovoljan ili imate neki drugi razlog
Kako ograničiti uređivanje za određene ćelije u Google tablicama
Kako ograničiti uređivanje za određene ćelije u Google tablicama
Ako Google tablice koristite za posao ili za organizaciju, ključno je zaključavanje ili zaštita imovine na drugi način. Slučajna izmjena ili brisanje, zlonamjerne promjene ili općenite nestašluke ili pogreške mogu uzrokovati gubitak posla i dok
Događaj Microsoftova ureda događa se 2. studenog
Događaj Microsoftova ureda događa se 2. studenog
Ranije ovog mjeseca Microsoft je poslao pozivnice za tisak za svoj Office Office u studenom 2016. godine. Nije jasno što će točno tvrtka najaviti tijekom tog događaja, ali možete očekivati ​​da ćete vidjeti ne samo nadolazeće promjene za Office 365 već i neke nove proizvode. Tu je vjerojatno dugogodišnji konkurent Slacku, Microsoft